Overview of incoming advisories.
2185 results found
CVE-2026-72860 describes a Server-Side Request Forgery (SSRF) vulnerability in the 9router application affecting the POST /api/provider-nodes/validate endpoint. The SSRF guard (assertPublicUrl) in ssrfGuard.js performs only string-based hostname comparison without DNS resolution or redirect revalidation. Its IPv4-mapped IPv6 blocking regex is rendered unreachable because the WHATWG URL parser canonicalizes addresses like ::ffff:127.0.0.1 into hextet notation (e.g., ::ffff:7f00:1) before the guard evaluates them, allowing all such addresses to bypass the check. Attackers can reach loopback and link-local metadata endpoints, perform blind internal port scanning via timing and status code differences, and exfiltrate up to 200 bytes of internal response bodies through the custom-embedding branch. The caller-supplied apiKey is forwarded as an Authorization Bearer header to internal targets, amplifying the risk. By default, exploitation requires a dashboard session, but is unauthenticated when requireLogin is disabled.
View original advisory →A heap out-of-bounds write vulnerability exists in libevent prior to versions 2.1.13 and 2.2.2-alpha. The flaw is located in bufferevent_sock.c, where bufferevent_socket_set_conn_address_ improperly copies a kernel-supplied AF_UNIX peer address into a smaller fixed-size field. Release builds compiled with NDEBUG disable the EVUTIL_ASSERT length guard, allowing the evhttp accept path to pass a 110-byte sockaddr into a 28-byte field. An unauthenticated local attacker who can connect to an AF_UNIX listener can exploit this to overwrite adjacent heap data including the dns_request pointer. This leads to memory corruption with potential confidentiality, integrity, and availability impact. The vulnerability has been patched in libevent versions 2.1.13 and 2.2.2-alpha.
View original advisory →CVE-2026-17422 is a buffer overflow vulnerability affecting IBM AIX versions 7.2 and 7.3, as well as IBM PowerVM VIOS 4.1. The vulnerability allows a local attacker to execute arbitrary code on affected systems. The flaw is classified as a local privilege escalation risk due to its buffer overflow nature. IBM has published a support advisory addressing the issue. The vulnerability impacts enterprise-grade Unix operating systems and virtualization infrastructure commonly used in critical business environments. Given the potential for arbitrary code execution, the risk is rated high.
View original advisory →CVE-2026-17157 affects IBM AIX versions 7.2 and 7.3, as well as IBM PowerVM VIOS 4.1. The vulnerability is a stack buffer overflow that could allow a remote attacker to execute arbitrary code on affected systems. No authentication appears to be required for exploitation, making this a critical remote code execution risk. IBM has published a support advisory with remediation guidance. The affected platforms are enterprise-grade Unix and virtualization infrastructure commonly used in large organizations. Given the nature of stack buffer overflows and remote exploitability, the potential impact is severe.
View original advisory →CVE-2026-55642 affects dbx, a cross-platform database client, in versions prior to 0.5.51. The vulnerability exists in the dbx-web component where the auth_middleware in auth.rs bypasses authentication entirely when password_hash is None. This condition occurs on fresh deployments where DBX_PASSWORD is unset and no stored password exists. Since the service binds to 0.0.0.0 on port 4224 by default, an unauthenticated remote attacker can access the /api/connection/connect and /api/query/execute API routes. Exploitation allows the attacker to leverage configured database credentials to execute arbitrary SQL commands, enabling data disclosure, modification, or destruction. The desktop Tauri application variant is not affected as it binds only to the loopback interface. The issue has been patched in version 0.5.51.
View original advisory →